Posting a message to the forum will remove the above advertisement

Discuss Some radiators not heating up in the Central Heating Forum area at UKPlumbersForums.co.uk.

  1. McNulty

    McNulty Member

    Sorry presses send by accident

    hi there,

    Haven’t posted in a while but please looking for any advice/help.

    Installed a new vertical column rad recently downstairs, drained system as usual, filled system back up and now about 3 rads aren’t getting hot downstairs (downstairs rads are on drops) I tried to balance the system thinking the rads couldn’t achieve the correct flow now I installed the vertical
    Rad, but when I did this the cold rads got hot but others started getting cold, if that makes sense, am I balancing them wrong?

    It’s a pressurised system, it does have a small single manifold that supply’s underfloor heating in a conservatory, but the heating all worked fine before. Could it be the pump that’s not strong enough with this new column rad?

    I’ve now got a problem with the furthest 2 radiators away, they’re not hot but the flow pipe coming down the wall is hot, so could it be a blockage? Lockshields and trvs seem fine I’m sure.

    Tbh I’m hoping it’s a blockage or air, but just wondered if anyone had any ideas.

    Many Thanks in advance
     
    Last edited by a moderator: Dec 4, 2017
  2. Vee

    Vee Plumber GSR

    Sounds like an air lock. Might have to chase it round by turning the rads that do come on off till you can push it out. With hot water off if heated by cylinder.
     
Loading...
Similar Threads - radiators heating Forum Date
Worcester boiler not heating radiators? Central Heating Forum Nov 9, 2017
Elderly central heating system - cold radiators Central Heating Forum Nov 4, 2017